sc2mosta

LE LANGAGE DE PROGRAMMATION PASCAL .
 
AccueilPortailCalendrierGalerieFAQRechercherMembresGroupesS'enregistrerConnexion
Rechercher
 
 

Résultats par :
 
Rechercher Recherche avancée
Derniers sujets
» NOTE EMD1 + EMD2+ DS + RAT. 2010-2011
Dim 18 Sep - 13:58 par maachou mohamed

» TD NO 02
Mer 14 Sep - 18:12 par BENYAMINA MOHAMED RABEH

» cours numéro 03
Mer 14 Sep - 15:19 par belhocine faycal.g1

» cours numéro 02
Mar 13 Sep - 18:19 par BENYAMINA MOHAMED RABEH

» cours numéro 01
Mar 13 Sep - 18:19 par BENYAMINA MOHAMED RABEH

» cours numéro 06
Mar 13 Sep - 18:19 par BENYAMINA MOHAMED RABEH

» cours numéro 04
Mar 13 Sep - 18:18 par BENYAMINA MOHAMED RABEH

» pascal en arabe
Mar 13 Sep - 18:18 par BENYAMINA MOHAMED RABEH

» cours numéro 08
Mar 13 Sep - 18:17 par BENYAMINA MOHAMED RABEH

Marque-page social
Conservez et partagez l’adresse de sc2mosta sur votre site de social bookmarking
Navigation
 Portail
 Index
 Membres
 Profil
 FAQ
 Rechercher
Forum
Partenaires
Forum gratuit



Tchat Blablaland

Partagez | 
 

 TD NO 02

Aller en bas 
Aller à la page : 1, 2, 3 ... 7 ... 14  Suivant
AuteurMessage
Admin
Admin
avatar

Messages : 23
Points : 39
Réputation : 16
Date d'inscription : 15/03/2008
Age : 57
Localisation : MOSTAGANEM

MessageSujet: TD NO 02   Lun 24 Mar - 13:07

Fiche TD N° 2
EXERCICE SUR LES BOUCLES :

Exercice N° 01 :
1. Ecrire l'algorithme - En utilisant la boucle «Pour » - qui permet de :
a) Lire au clavier un nombre N ;
b) Calculer S = 1 + 1/2 + 1/3 + 1/4 + 1/5 + + l/N ;
2. Traduire cet algorithme en programme Pascal.

Exercice N° 02 :
Répondre aux questions de l'exercice N° 1 en utilisant:
1. La boucle «répéter » ;
2. La boucle «Tant que ».

Exercice N° 03 :
Ecrire l'algorithme puis le programme qui permet d'afficher le Maximum
Max. Et le Minimum Min de N nombre lit au clavier.

Exercice N° 04 :
1. Ecrire l'algorithme qui permet de :
a) Lire un nombre N au clavier;
b) Affiche tous les diviseurs de ce nombre
2. Traduire Cet algorithme en programme pascal.

Exercice N°05 :
1. Ecrire l'algorithme qui permet de :
a) Lire un nombre N au clavier ;
b) Compter le nombre de ses diviseurs;
c) Calculer la somme de ses diviseurs ;
d) En déduire si N est premier ;
e) En déduire si N est parfait;
On dit que N est parfait si N = Σ diviseurs(N). Exemple 6 est parfait car (6 = 1 + 2 + 3)
2. Ecrire le programme pascal correspond à cet algorithme.

Exercice N°06:
1. Ecrire l'Algorithme qui permet de :
a) Lire deux nombres A et B au clavier;
b) Calculer le PGDC(A,B) par l' Algorithme d’Euclide ;
c) En déduire le PPMC(A, B) ; Sachant que PPMC(A,B)= A*B/PGDC(A,B)
d) En déduire si A et B sont premiers entre eux ;
2. Traduire cet algorithme en programme pascal.


SOLUTION TD NO 02


EXERCICE 01 :

ALGORITHME

DEBUT
I , N : ENTIER
S : REEL
LIRE ( N )
S<-- 0
POUR I <--1 JUSQU'À N FAIRE
S <-- S + 1/I
FIN POUR
AFFICHER( S )
FIN

PROGRAMME PASCAL

PROGRAM TD02EX01;
VAR
I , N : INTEGER ;
S : REAL ;
BEGIN
READ( N ) ;
S := 0 ;
FOR I := 1 TO N DO
S := S + 1/I ;
WRITE ( S ) ;
END.



EXERCICE 02 :

ALGORITHME AVEC REPETER

DEBUT
I , N : ENTIER
S : REEL
LIRE ( N )
S<-- 0
I <--1
REPETER
S <-- S + 1/I
I <-- I +1
JUSQU’A I > N
AFFICHER ( S )
FIN

PROGRAMME PASCAL AVEC REPEAT

PROGRAM TD02EX02;
VAR
I , N : INTEGER ;
S : REAL ;
BEGIN
READ( N ) ;
S := 0 ;
I:=1 ;
REPEAT
S := S + 1/I ;
I := I + 1
UNTIL I > N ;
WRITE(S);
END.


ALGORITHME avec TANT QUE
DEBUT
I , N : ENTIER
S : REEL
LIRE ( N )
S<-- 0
I <--1
TANT QUE I < N FAIRE
S <-- S + 1/I
I <-- I +1
FIN TANTQUE
AFFICHER ( S )
FIN

PROGRAMME PASCAL AVEC WHILE

PROGRAM TD02EX02BIS ;
VAR
I , N : INTEGER ;
S : REAL ;
BEGIN
READ( N ) ;
S := 0 ;
I:=1 ;
WHILE I < N DO
BEGIN
S := S + 1/I ;
I := I + 1
END;
WRITE(S);
END.


EXERCICE 03 :

ALGORITHME

DEBUT
I , N , MIN , MAX , NBRE : ENTIER
LIRE ( NBRE )
MAX <-- NBRE
MIN <-- NBRE
POUR I<-- 2 JUSQU’A N FAIRE
LIRE ( NBRE )
SI NBRE > MAX ALORS
MAX <-- NBRE
FINSI
SI NBRE < MIN ALORS
MIN <-- NBRE
FINSI
FIN POUR
FIN

PROGRAME PASCAL

PROGRAM TD02EX03;
VAR
I , N , MIN , MAX , NBRE : INTEGER ;
BEGIN
READ ( NBRE) ;
MAX := NBRE ; MIN := NBRE ;
FOR I := 2 TO N DO
BEGIN
READ ( NBRE) ;
IF NBRE > MAX THEN
MAX := NBRE ;
IF NBRE < MIN THEN
MIN := NBRE
END;
WRITELN ( MAX , MIN );
END.



EXERCICE 04

ALGORITHME

DEBUT
I , N : ENTIER
LIRE ( N )
POUR I<-- 1 JUSQU'A N FAIRE
SI MOD( N ,I ) = 0 ALORS
AFFICHER( ’Le diviseur de ’, N , ’est’,I )
FINSI
FIN POUR
FIN

PROGRAMME PASCAL

PROGRAM TD02EX04 ;
VAR
I , N : INTEGER ;
BEGIN
READ( N ) ;
FOR I := 1 TO N DO
IF MOD( N , I ) THEN
WRITELN (’Le diviseur de ’, N , ’est’,I ) ;
END.



EXERCICE 05

ALGORITHME

DEBUT
I , N , NBDIV , S : ENTIER
LIRE ( N )
NBDIV<--0
S<--0
POUR I<-- 1 JUSQU'A N FAIRE
SI MOD( N ,I ) = 0 ALORS
NBDIV <- NBDIV + 1
S <-- S + I
FINSI
FIN POUR
SI NBDIV = 2 ALORS
AFFICHER ( N,’est premier’)
FINSI
SI N = S ALORS
AFFICHER ( N,’est parfait’)
FINSI
FIN

PROGRAMME PASCAL

PROGRAM TD02EX05 ;
VAR
I , N , NBDIV , S : INTEGER ;
BEGIN
READ( N ) ;
NBDIV :=0 ;
S :=0 ;
FOR I := 1 TO N DO
IF MOD( N , I ) = 0 THEN
BEGIN
NBDIV := NBDIV + 1;
S := S + I
END;
IF NBDIV = 2 THEN
WRITE (N,’est premier’);
IF N = S THEN
WRITE (N,’est parfait);
END.


EXERCICE 06

ALGORITHME

DEBUT
A , B , D , PGDC , PPMC : ENTIER
LIRE ( A , B )
REPETER
D <-- A MOD B
A <-- B
B <-- D
JUSQU’A D=0
FIN REPETER
PGCD<-- B
PPMC <-- A*B/PGCD
SI PGCD = 1 ALORS
AFFICHER( A,’et’,B,’sont premier entre eux’)
FINSI
AFFICHER(A , B , PGCD , PPMC)
FIN

PROGRAMME PASCAL

PROGRRAM TD02EX06 ;
VAR
A , B , D , PGCD , PPMC : INTEGER ;
BEGIN
READ ( A , B ) ;
REPEAT
D:= A MOD B;
A:= B ;
B := D
UNTIL D = 0 ;
PGCD := B;
PPMC := A*B/PGCD;
IF PGCD = 1 THEN
WRITE(A,’et’,B,’sont premier entre eux’) ;
WRITE(A , B , PGCD , PPMC) ;
END.
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://sc2mosta.forums-actifs.com
Benguendouz Abdelkrim

avatar

Messages : 7
Points : 26
Réputation : 0
Date d'inscription : 19/11/2008
Localisation : Mostaganem

MessageSujet: Re: TD NO 02   Sam 7 Fév - 14:54

pour telecharger cette version instalable clicker sur le lien ke je vous est fourni si dessou lol! @
Idea 4shared.com/get/36642628/d15abf8/Turbo_Pascal_70__Setup_.html


Merciiiiiiiiiiiiiiiiiii a notre cher Adminnnn [i] Pour les Fiche TD Idea
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://pascal.developpez.com/
KREIRI AKILA

avatar

Messages : 85
Points : 118
Réputation : 3
Date d'inscription : 09/12/2009
Age : 33
Localisation : mostaganem

MessageSujet: salam   Jeu 17 Déc - 20:59

alor a+ by et merci
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
KREIRI AKILA

avatar

Messages : 85
Points : 118
Réputation : 3
Date d'inscription : 09/12/2009
Age : 33
Localisation : mostaganem

MessageSujet: salam   Ven 25 Déc - 21:06

salam
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
larabi*maamar

avatar

Messages : 97
Points : 127
Réputation : 0
Date d'inscription : 17/12/2009
Age : 49
Localisation : algerie. mostaganem

MessageSujet: bonsoir !   Dim 27 Déc - 22:47

[b]salam alikom
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
larabi*maamar

avatar

Messages : 97
Points : 127
Réputation : 0
Date d'inscription : 17/12/2009
Age : 49
Localisation : algerie. mostaganem

MessageSujet: salam alikom   Dim 27 Déc - 23:23

Revenir en haut Aller en bas
Voir le profil de l'utilisateur
belhadji
Invité



MessageSujet: slm   Lun 4 Jan - 21:03

salèm 3likom,je ss de group 01
Revenir en haut Aller en bas
chahra
Invité



MessageSujet: slt   Mer 6 Jan - 21:25

salut je suis ouadenni chahrazed du groupe 07
Revenir en haut Aller en bas
MISSOUM
Invité



MessageSujet: SALUT   Jeu 7 Jan - 1:08

SLM JE SUIS VOTRE ETUDIANTE DE 2EME ANNée DE GOUPE 07
Revenir en haut Aller en bas
larabi*maamar

avatar

Messages : 97
Points : 127
Réputation : 0
Date d'inscription : 17/12/2009
Age : 49
Localisation : algerie. mostaganem

MessageSujet: Vive L'algerie   Ven 8 Jan - 20:12

bonsoir je suis G06
lol!
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
MAZARI I
Invité



MessageSujet: SALUT   Jeu 4 Fév - 12:52

salam alikom moi mazari ibrahim du groupe 6
Revenir en haut Aller en bas
MOSTEFAI
Invité



MessageSujet: BONJOUR   Jeu 4 Fév - 12:56

Bonjour je suis mostefai khadidja leila du groupe 7 Smile
Revenir en haut Aller en bas
MOSTEFAI
Invité



MessageSujet: SALUT   Jeu 4 Fév - 12:59

SALUT JE SUIS MOSTEFAI TATA FATIMA ZOHRA Rolling Eyes
Revenir en haut Aller en bas
chenine afif nouredine

avatar

Messages : 51
Points : 70
Réputation : 0
Date d'inscription : 19/01/2010
Age : 28
Localisation : bosquet

MessageSujet: Re: TD NO 02   Lun 8 Fév - 17:01

slt prof cheers
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
bouzidi



Messages : 9
Points : 13
Réputation : 0
Date d'inscription : 14/12/2009

MessageSujet: salam   Lun 8 Fév - 17:46

salam sava
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
fatima abbou

avatar

Messages : 41
Points : 62
Réputation : 0
Date d'inscription : 16/01/2010
Localisation : mostaganem

MessageSujet: slt   Lun 8 Fév - 19:48

salam 3alikom
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Benalioua Yahya

avatar

Messages : 71
Points : 139
Réputation : 1
Date d'inscription : 28/01/2010

MessageSujet: Re: TD NO 02   Lun 8 Fév - 23:28

benalioua yahya G2: (bonne nuit);
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
bouzidi



Messages : 9
Points : 13
Réputation : 0
Date d'inscription : 14/12/2009

MessageSujet: salam   Jeu 11 Fév - 22:45

slt a tout santa
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
benslima
Invité



MessageSujet: salam   Ven 12 Fév - 20:39

SALAM PROF C FATIMA ZOHARA BENSLIMANE 2 éME ANNéE SC2 G N°= INCHALAH YATAKABAL RABANA MINA SALATANA W 3AMALANA W NAKOUNA MINA NAJIHIN
Revenir en haut Aller en bas
chenine afif nouredine

avatar

Messages : 51
Points : 70
Réputation : 0
Date d'inscription : 19/01/2010
Age : 28
Localisation : bosquet

MessageSujet: Re: TD NO 02   Sam 13 Fév - 14:59

merci prof Very Happy
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
KREIRI AKILA

avatar

Messages : 85
Points : 118
Réputation : 3
Date d'inscription : 09/12/2009
Age : 33
Localisation : mostaganem

MessageSujet: salam   Sam 13 Fév - 20:15

salam sava a tout
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
chenine afif nouredine

avatar

Messages : 51
Points : 70
Réputation : 0
Date d'inscription : 19/01/2010
Age : 28
Localisation : bosquet

MessageSujet: Re: TD NO 02   Sam 13 Fév - 22:28

slt a tous cheers
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Bendref Belkacem



Messages : 41
Points : 58
Réputation : 0
Date d'inscription : 16/11/2009

MessageSujet: Re: TD NO 02   Mar 16 Fév - 12:21

bendref belkacem G2
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
BOUAAZA
Invité



MessageSujet: salut   Mar 16 Fév - 20:33

salut je ss bouaaza mostapha G03 Basketball
Revenir en haut Aller en bas
benalioua yasmine



Messages : 22
Points : 34
Réputation : 0
Date d'inscription : 09/02/2010

MessageSujet: Re: TD NO 02   Mer 17 Fév - 18:14

merciiii pour tout Very Happy
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Contenu sponsorisé




MessageSujet: Re: TD NO 02   

Revenir en haut Aller en bas
 
TD NO 02
Revenir en haut 
Page 1 sur 14Aller à la page : 1, 2, 3 ... 7 ... 14  Suivant

Permission de ce forum:Vous ne pouvez pas répondre aux sujets dans ce forum
sc2mosta :: TD et SUJET,CORRECTION ET NOTES EMD-
Sauter vers: